Agent not receiving ML based suggestions
Scenario - Agent not receiving ML based suggestions
Problem Description
Agent is not giving a classification or compliance tag ML suggestion on the document opened by the user.
Potential Cause 1
The classifier service is down. This service is responsible for sending suggestions to the agent.
Solution
Follow the Prerequisites section to know the steps to check the status and logs of the classifier service
The service status will be reviewed from the Rancher Web UI
Potential Cause 2
The classification confidence level not reaching the threshold defined in the agent.
Solution
The default classification confidence defined in agent is 0.60 (60 %)
Either you have to bring down the threshold or increase the confidence value defined in the Getvisibility Management server.
The threshold can be brought down by login to the Windows machine where the agent is installed and edit the below mentioned file.
C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\GVClient.Service\GVClient_Service_Properties.config.json |
Update the value of variable "ConfidenceSuggestionThreshold" to the required value.
Restart the “Getvisibility” service.
Potential Cause 3
Agent configuration’s suggestion section is misconfigured
Solution
Agent configuration contains the following section.
The “key” value should be pointing to the right ID.
Each set of tags should have a specific ID defined to that. For Example, Getvisibility default classification tagset is “b4c70d4c-e8af-4331-ba0c-733721d06495” and for Compliance is “00000000-0000-0000-0000-000000002001”
So the custom tag set have a different value, reach out to getvisibility team to know about it.
"suggestionOptions" : [ { "key" : "b4c70d4c-e8af-4331-ba0c-733721d06495", "tagset" : "e16409a7-1700-4153-9090-3955bc2f0ae8", "tag" : "Classification" }, { "key" : "00000000-0000-0000-0000-000000002001", "tagset" : "f14fc1f1-8950-40d5-8a29-45909da947d6", "tag" : "GDPR/PII" } ] |
Related content
Classified as Getvisibility - Partner/Customer Confidential