Agent not receiving suggestions on the defined regex pattern
Scenario - Agent not receiving suggestions on the defined regex pattern
Problem Description
Agent is not giving a classification or compliance tag suggestion on the regex pattern found in the document opened by the user.
Potential Cause 1
The classifier service is down. This service is responsible for sending suggestions to the agent.
Solution
Follow the Prerequisites section to know the steps to check the status and logs of the classifier service
The service status will be reviewed from the Rancher Web UI
Potential Cause 2
The classification confidence level defined for the regex is lower than the defined threshold to provide a suggestion.
Solution
The default classification confidence defined in agent is 0.60 (60 %)
Either you have to bring down the threshold or increase the confidence value defined in the Getvisibility Management server.
The threshold can be brought down by login to the Windows machine where the agent is installed and edit the below mentioned file.
C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\GVClient.Service\GVClient_Service_Properties.config.json |
Update the value of variable "ConfidenceSuggestionThreshold" to the required value.
The second approach would be to redefine the classification confidence level of the regex in the classifier service in the Getvisibility Management Server.
Reach out to the GV team to make the required changes to the regex pattern
Potential Cause 3
The regex is mis-configured in the background
Solution
The regex pattern is mis-configured and won’t trigger on the expected pattern.
Reach out to the GV team to make the required changes to the regex pattern
Related content
Classified as Getvisibility - Partner/Customer Confidential