Contents
Document Details
Prepared By | Reviewed By | Date | Document Version |
Ashima Agarwal | Artem Kalaitan | 5-July-2022 | V1 |
Introduction
This document contains multiple knowledge articles related to Synergy.
Articles
License Management Process
Refer the attached document for the detailed information about the process
Hold-Revoke License
Refer the attached document for the detailed information about the process
Installation -Upgrade K3s: - Register Server – Reseller
Refer the attached document for the detailed information about the process
Installation -Upgrade K3s: - Deploy Synergy – Reseller
Refer the attached document for the detailed information about the process
Installation -Upgrade K3s: - Install Server – Client
Refer the attached document for the detailed information about the process
Installation -Upgrade K3s:- Update – Client
Refer the attached document for the detailed information about the process
Installation -Upgrade K3s:- Backup – Client
Refer the attached document for the detailed information about the process
Troubleshooting Synergy with Sentry
Refer the attached document for the detailed information about the process
Troubleshooting Synergy with Sentry
Synergy Agent – Auto Update Feature
Refer the attached document for the detailed information about the process
Synergy Agent - AutoUpdate Feature
Basic Installation Method – Synergy
Refer the attached document for the detailed information about the process
Deploy MSI for Synergy Product
Installation through CLI - Synergy
Refer the attached document for the detailed information about the process
Deploy MSI for Synergy Product
Installation through group policy (GPO) – Synergy
Refer the attached document for the detailed information about the process
Deploy MSI for Synergy Product
Installation through SCCM – Synergy
Refer the attached document for the detailed information about the process
Deploy MSI for Synergy Product
Installation of the Generic Agent-Synergy
Refer the attached document for the detailed information about the process
Deploy MSI for Synergy Product
Deployment of Forcepoint Classification Using Rancher
Refer the attached document for the detailed information about the process
GV Icon is grayed out
Refer the attached document for the detailed information about the process
Getting suggestions on the limited document
Problem Description
Agent not throwing suggestions on all kinds of documents, this could occur because the file’s content is quite large for the classifier to process.
Potential Cause
The classifier is timing out while processing the document's content.
Solution
Classifier needs to re-configured to consume the files of bigger size and also spend more time on processing the files before timing out
Reach out to the Getvisibility team support@getvisibility.com in case of this issue is encountered
Agent not receiving suggestions on the defined regex pattern
Refer the attached document for the detailed information about the process
Agent not receiving suggestions on the defined regex pattern
Agent not receiving ML based suggestions
Refer the attached document for the detailed information about the process
Agent not receiving ML based suggestions
Citrix/vSphere incompatibility
Refer the attached document for the detailed information about the process
Citrix-vSphere incompatibility
UIWPF Loader Crashed
Refer the attached document for the detailed information about the process
Slowness in receiving AI/ML Suggestion
Refer the attached document for the detailed information about the process
Slowness in receiving AI-ML Suggestion
Agent does not receive newest configuration
Refer the attached document for the detailed information about the process
Agent does not receive newest configuration
Configuration Wizard unable to push the json on the Dashboard
Refer the attached document for the detailed information about the process
Configuration Wizard unable to push the json on the Dashboard
Agent not listed on the Agent management console
Refer the attached document for the detailed information about the process
Agent not listed on the Agent management console
Firewall Whitelisting – Synergy
Refer the attached document for the detailed information about the process
Firewall Whitelisting - Synergy
Supporting Services – Synergy
Refer the attached document for the detailed information about the process
Collecting Logs – Synergy
Refer the attached document for the detailed information about the process
Kafka service Down
Refer the attached document for the detailed information about the process
Agent cannot connect to the GV Management Server
Agent cannot connect to the GV Management Server because of network restrictions
Solution
Add a rule on the Network Firewall to allow the agent to communicate with the backend Getvisibility server on port 59093
The classifier is timing out while processing the document's content
Solution
Classifier needs to re-configured to consume the files of bigger size and also spend more time on processing the files before timing out
Reach out to the Getvisibility team support@getvisibility.com in case of this issue is encountered
The classifier service is down
Refer the attached document for the detailed information about the process
The classifier service is down
The classification confidence level defined for the regex is lower than the defined threshold to provide a suggestion.
Solution
The default classification confidence defined in agent is 0.60 (60 %)
Either you have to bring down the threshold or increase the confidence value defined in the Getvisibility Management server.
The threshold can be brought down by login to the Windows machine where the agent is installed and edit the below mentioned file.
C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\GVClient.Service\GVClient_Service_Properties.config.json |
Update the value of variable "ConfidenceSuggestionThreshold" to the required value.
The second approach would be to redefine the classification confidence level of the regex in the classifier service in the Getvisibility Management Server.
Reach out to the GV team support@getvisibility.com to make the required changes to the regex pattern
The regex is mis-configured in the background
Solution
The regex pattern is mis-configured and won’t trigger on the expected pattern.
Reach out to the GV team to make the required changes to the regex pattern
The configuration pushed is not compatible with the Agent
Check the version defined in the agent configuration, it should be the same as the version of the agent installed but only till the first decimal value.
For Example, for the agent with version 2.9.0 will be compatible with the configuration with the version defined as “2.9”
The snippet of the agent configuration:
{ "id": "8e808d12-fdc4-4fc9-8938-853b0a4a5d3d", "timeStamp": "2021-12-15T10:45:07.523+01:00[Europe/London]", "version": "2.9", "notes": "Sample configuration": { "id": "e16409a7-1700-4153-9090-3955bc2f0ae8", "tags": [ "Public", "General Business Use", "Confidential", "Highly-Confidential" ] }, |
The agent and the audit service are not running.
Refer the attached document for the detailed information about the process
Agent and Audit service are not running
Excel is working slowly
If the user is facing the issue that excel is working slow then in the config of the agent change the excelTextForwardingActive = False, this will help resolve the issue.
Excel App crashing
A generic solution is to capture the logs as per the document attached.
Agent is writing incorrect column order in the dialog configuration block
This is a known issue and will be resolved in future releases.
Compatibility with MDM devices
We need to provide a list what MDM we support - i.e. SCCM, workspace1, mac mdm solutions - Jamf
We do not support mobile solutions but sometimes clients will install software using the install packages on the MDM devices like Microsoft System Center Configuration Manage (SCCM),Google - Workspace1 and Apple - Jamf.
Excel "Save as - Browse" functionality not working. User can’t save a file to chosen directory
This is a known issue and will be resolved in future releases.
Powerpoint unable to enforce ForceTaggingDirtyBuffers setting
This is a known issue and will be resolved in future releases.
Unable to install agent because of limited access level
Refer the attached document for the detailed information about the process
Deploy MSI for Synergy Product
Unable to Install agent in the offline environment (that has no outbound access to internet)
Refer the attached document for the detailed information about the process
Deploy MSI for Synergy Product
Unable to open Synergy dashboard
Refer the attached document for the detailed information about the process
Unable to open Synergy dashboard
End Of Document